Start Process and Ajax pages

Questions and Answers about programming Helium Scraper.
Post Reply
BalooBear
Posts: 2
Joined: Thu Sep 12, 2013 1:28 pm

Start Process and Ajax pages

Post by BalooBear » Wed Mar 05, 2014 1:30 pm

Hi Juan,

I've been successfully running multiprocess scripts, however I'm running into a particular problem whereby when the new process window script opens, some of my kinds are not found on the page? This, of course, causes my script to fail. If I navigate to the spawned helium window running and stop it manually (i.e. interrupt the wait 10000 as the top of my script), then run the action that should be working, it works. All kinds are present and can be found as expected.

Also, if I run the same script, as a non-multiprocess, it runs fine and finds all the kinds as well.

I've tried various techniques to remedy this to no avail.
- Scrolling the page via JavaScript to ensure that the whole page has loaded (I can see the whole page has loaded, including the bits I've made kinds for)
- Using force select action for the kind I'm interested in
- Waiting actions, scrolling, waiting, scrolling,
- If/While actions
but nothing seems to work until I manually stop the script and then run the same action.

Strangely, some kinds (even dynamically loaded on the page kinds) work just fine.

Is there a way to emulate a process.stop and then continue it? It feels like an old VBA problem whereby you need to issue a do events() to allow the process to catchup?

I hope you have a bit of time to direct me in the right direction and if anyone else reading this could help I would appreciate that too!

PS: Great product, I hope can continue with future releases... and support.

Post Reply