URI Formats are not supported? *SOLVED*

Questions and answers about anything related to Helium Scraper
Post Reply
iana1uk
Posts: 6
Joined: Sat Jul 09, 2011 1:01 pm

URI Formats are not supported? *SOLVED*

Post by iana1uk » Fri Jul 22, 2011 11:23 pm

Hi, I upgraded to the full version today.

One minor issue, I keep getting this error message (URI Formats are not supported), this happens when I double click on a pre-saved xxx.hsp file to open it in Helium Scraper.

If I run Helium Scraper first, then open the xxx.hsp file - I don't get the error.

Just wondering what it was and why it's happening?

thanks.
Last edited by iana1uk on Sat Jul 23, 2011 8:12 am, edited 1 time in total.

webmaster
Site Admin
Posts: 495
Joined: Mon Dec 06, 2010 8:39 am
Contact:

Re: URI Formats are not supported?

Post by webmaster » Sat Jul 23, 2011 2:38 am

Hi,

Is this file on a virtual directory? What happens if you copy it to another folder such as your desktop and try to open it by double clicking it?
Juan Soldi
The Helium Scraper Team

iana1uk
Posts: 6
Joined: Sat Jul 09, 2011 1:01 pm

Re: URI Formats are not supported?

Post by iana1uk » Sat Jul 23, 2011 7:56 am

It's on a mapped network drive on a Windows XP Pro machine. I am opening it using a laptop with Windows 7.

I've copied it to my desktop, opened it and the same thing happens.
I've created a new one from scratch and saved it to the desktop, opened it and the same thing happens.

I've attached a test hsp file, if it's any use.
Attachments
test-saved-to-desktop.hsp
(289.65 KiB) Downloaded 224 times

iana1uk
Posts: 6
Joined: Sat Jul 09, 2011 1:01 pm

Re: URI Formats are not supported? *SOLVED*

Post by iana1uk » Sat Jul 23, 2011 8:12 am

Hi,

I've just upgraded to v2.0.3.2 and the problem has gone away! Problem solved. Thanks for your quick replies and help.

Something else I've noticed, not sure if this is also now fixed as it occurred while using the older version:

I kept re-using the same hsp file for different scraping jobs and even though I was deleting the database for each re-use, the hsp file was getting bigger and bigger, even though I was deleting the tables and data each time. It was at about 40MB at one point before I decided to do something about it - so I loaded the database into MS Access and and packed/optimised it to remove all the deleted database tables etc. This cured the problem.

Like I said, not sure if it is now fixed, but perhaps an option to optimise/pack the database ?

webmaster
Site Admin
Posts: 495
Joined: Mon Dec 06, 2010 8:39 am
Contact:

Re: URI Formats are not supported? *SOLVED*

Post by webmaster » Sat Jul 23, 2011 4:41 pm

Hi,

The database gets compressed automatically when you save your file since version 2.0.3.2 so you shouldn't have that problem anymore.
Juan Soldi
The Helium Scraper Team

iana1uk
Posts: 6
Joined: Sat Jul 09, 2011 1:01 pm

Re: URI Formats are not supported? *SOLVED*

Post by iana1uk » Sun Jul 24, 2011 9:39 pm

Ah, nice one! Thanks again.

Post Reply