"Next" kind doesn't advance pages

Here you can ask anything related to JavaScript as applied to Helium Scraper.
Post Reply
jcmcginty
Posts: 1
Joined: Tue Mar 12, 2013 4:44 pm

"Next" kind doesn't advance pages

Post by jcmcginty » Tue Mar 12, 2013 4:55 pm

Hi,

I'm trying to scrape a series of javascript pages. I've created and tested all of the kinds needed for this, including a "Next" kind. Each one tests perfectly. But when I "play" the scrape, it never advances past the first page.

I made the "Next" kind per instructions in the tutorial:I selected "next page" on the first page that I'm interested in scraping, and I created a kind based on that selection. I turned of the select too, manually advanced to the second page, turned the select tool back on, selected "next page" and added it to the kind. When I tested the kind, it did find "next page" on whatever page I happen to be on. But when I hit "play," only data on the first page was captured.

I did change the "repeat" number to the correct number of pages, but instead of advancing through the pages, "play" captures the first page repeatedly.

If anyone has any tips or can steer me toward help on this subject, I'd appreciate it!

J

webmaster
Site Admin
Posts: 491
Joined: Mon Dec 06, 2010 8:39 am
Contact:

Re: "Next" kind doesn't advance pages

Post by webmaster » Thu Mar 14, 2013 3:05 pm

Have you tried checking the Simulate Click option? Also, see if adding a Wait action of 1000-2000 milliseconds right after the Navigate action helps.
Juan Soldi
The Helium Scraper Team

Post Reply