Page 1 of 1

Helium Scraper Refusing to load.

Posted: Sun Feb 15, 2015 11:42 am
by gibbon666
When I try to start Helium Scraper, I get "An unexpected error occured and the application may be in a corrupted state."

I have tried uninstall and reinstall with no luck.

I had left it running a scrape overnight and this error occured this morning.

Report is below...

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<Message>The file exists.
</Message>
<TypeName>System.IO.IOException</TypeName>
<StackTrace> at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.__Error.WinIOError()
at System.IO.Path.InternalGetTempFileName(Boolean checkHost)
at Player.Data.InternalDataBaseFile.ReCreateDataBase(Action`1 writeFile)
at Player.Data.InternalDataBaseFile..ctor()
at Player.DataBaseManager..ctor()
at Player.Project.BasicProject.SetDefaultValues()
at WebScraperAndPlayer.Project.SetDefaultValues()
at WebScraperAndPlayer.BuilderForm2.n()
at WebScraperAndPlayer.BuilderForm2.w()
at WebScraperAndPlayer.BuilderForm2.ak(Object A_0, EventArgs A_1)
at System.Windows.Forms.Form.OnShown(EventArgs e)
at System.Windows.Forms.Form.CallShownEvent()
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()</StackTrace>
<TimeStamp>2015-02-15T11:39:12.223861+00:00</TimeStamp>
<Version>2.4.1.4</Version>
<WorkingSet>41627648</WorkingSet>
<Is64Bit>true</Is64Bit>
<WinVersion>Microsoft Windows NT 6.1.7601 Service Pack 1</WinVersion>
<BrowserVersion>11.0.9600.17631</BrowserVersion>
</ErrorReport>

Re: Helium Scraper Refusing to load.

Posted: Mon Feb 16, 2015 7:48 am
by gibbon666
A bit more information...

I uninstalled and reinstalled - same error occurs.

I tried running this same scrape on my other pc. It seems to have broken Helium Scraper on that one as well with the same issue.

It's a multi-process scrape. Nothing immense - 2020 links and for each one it grabs an id, name and picture src.

It was set to run 5 processes at a time max. It was based on tons of other scrapes I've used successfully with pretty much identical settings.

I left it running and when I came back to it, it was around record 970 and the open processes had all stopped. One of them had an "Error in XML document" showing on screen.

As I closed the open processes and Helium tried to open new ones, each of those popped up with "File Exists".

After stopping the main process and re-opening Helium Scraper it seemed to open ok, but then as soon as I tried to open any scrape or do anything I got "File Exists".

Tried reopening Helium this morning. It looks like it isn't opening as it doesn't bring up the home page, but you can click on the menus. As soon as you click on New or Open you get "File Exists". The log from that is below.

Any help would be much appreciated as I have now broken Helium Scraper on both my PCs and I could do with using it.

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<Message>The file exists.
</Message>
<TypeName>System.IO.IOException</TypeName>
<StackTrace> at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.__Error.WinIOError()
at System.IO.Path.InternalGetTempFileName(Boolean checkHost)
at Player.Data.InternalDataBaseFile.ReCreateDataBase(Action`1 writeFile)
at Player.Data.InternalDataBaseFile..ctor()
at Player.DataBaseManager..ctor()
at Player.Project.BasicProject.SetDefaultValues()
at WebScraperAndPlayer.Project.SetDefaultValues()
at WebScraperAndPlayer.BuilderForm2.n()
at WebScraperAndPlayer.BuilderForm2.bc(Object A_0, EventArgs A_1)</StackTrace>
<TimeStamp>2015-02-16T07:46:06.9301716+00:00</TimeStamp>
<Version>2.4.1.4</Version>
<WorkingSet>48209920</WorkingSet>
<Is64Bit>true</Is64Bit>
<WinVersion>Microsoft Windows NT 6.1.7601 Service Pack 1</WinVersion>
<BrowserVersion>11.0.9600.17631</BrowserVersion>
</ErrorReport>

Re: Helium Scraper Refusing to load.

Posted: Mon Feb 16, 2015 10:58 am
by gibbon666
Just found a similar issue from someone else on the forum. Not sure why I didn't spot it before. I must have searched on the wrong part of the error.

They had solved it by deleting "C:\Users\<username>\AppData\Local\Temp"

I've just deleted 16GB of temp files on one of the pcs and scraper now loads fine. Will be interesting to see how many temp files are on the other pc.